Pi-Pan doesn't respond to software commands
 Raspberry Pi   Started by Alan Baker   2016-10-12 12:25:31 -04:00   Comments: 2    Viewed: 254

  1. Alan Baker
    Alan Baker Member
    When I issue software commands, nothing moves on my Pi-Pan.  I have a 2-amp supply powering a Raspberry Pi Model B rev 2, I think I have the wiring correct, and the software installed correctly. 

    Does the software get a response from the hardware about whether it moved?  Are there debugging tools or procedures to validate the installation?

    Alan Baker, 2016-10-12 12:25:31 -04:00
  2. Eugene Moore
    Eugene Moore Member
    Did you ever resolve this problem? I am having the same issue. I am running a Raspberryp Pi 3 B with RPi Pixel upgrade and the servos do not respond to software commands. The PiLight works perfectly, however. Like you, am running a good official power supply. The servos to auto neutral when I boot the pi up so power is, in fact, reaching the servos. I think the clue may be found in the servod error shown below:

    pi@raspberrypi:~/pi-pan $ sudo ./install-pi-pan.bash
    Updating config files...
    Updating PiPan and Pilight libraries...
    Pi-Light Install completed
    servod: Cannot parse the hardware name string
    Pi-Pan Install completed
    pi@raspberrypi:~/pi-pan $ sudo python check-pan.py
    Check that Pan servo is moving (horizontal movement)
    Eugene Moore, 2017-06-13 12:55:36 -04:00
  3. (You must log in or sign up to post here)

Log in | Sign up
Tems & Conditions!