04-Motor-Sync program causes LED (near F1) to blink red and program does not execute as expected.
 Hardware Related   Started by rkG   2020-01-31 14:12:40 -05:00   Comments: 5    Viewed: 624

  1. rkG
    rkG Member
    Hi All,

    I've recently been playing around and testing the different demo programs with the PiStorm brick, Raspberry Pi 3 and NXT motors.
    When I run a single motor, it runs with no issues and all other programs seem to execute perfectly. The moment I introduce a second motor (it doesn't have to be using setSpeedSync, even just turning on two motors at the same time with setSpeed) then the LED next to F1 starts blinking red and the program seems to crash. As far as I understand it that red LED blinking indicates that there isn't enough power for the system to continue running the program? However, I've tried using batteries to power the PiStorm and I've tried a variable power supply, which is rated 40V and 5A. The maximum current being recorded when any of the demo programs are run is 0.6A.

    I should also mention that on occasion, 04-Motor-Sync program runs as intended and so do some of my custom programs that use two motors. But this does not make sense to me at all.
    Furthermore, I recorded these errors from the log files (on the web interface):

    Swarm Server:

    Traceback (most recent call last):
      File "", line 127, in
      File "", line 22, in my_ip_address
      File "socket.py", line 224, in meth
    socket.error: [Errno 101] Network is unreachable
    swarmserver returned -1

    MSWeb:

     * Serving Flask app "MSWeb" (lazy loading)
     * Environment: production
       WARNING: Do not use the development server in a production environment.
       Use a production WSGI server instead.
     * Debug mode: off
     * Running on http://0.0.0.0:3141/ (Press CTRL+C to quit)
    192.168.1.112 - - [31/Jan/2020 19:00:00] "GET /device HTTP/1.1" 200 -
    192.168.1.112 - - [31/Jan/2020 19:00:00] "GET /firmware HTTP/1.1" 200 -
    192.168.1.112 - - [31/Jan/2020 19:00:00] "GET /eth0 HTTP/1.1" 200 -
    192.168.1.112 - - [31/Jan/2020 19:00:00] "GET /wlan0 HTTP/1.1" 200 -
    192.168.1.112 - - [31/Jan/2020 19:00:00] "GET /battery HTTP/1.1" 200 -
    192.168.1.112 - - [31/Jan/2020 19:00:00] "GET /software HTTP/1.1" 200 -
    192.168.1.112 - - [31/Jan/2020 19:00:00] "GET /getprogramsdir HTTP/1.1" 200 -

    If anyone has any clue or could point me in the right direction that would be great!

    Thanks,
    Tiz
    rkG, 2020-01-31 14:12:40 -05:00
  2. Nitin Patil
    Nitin Patil Member Staff Member
    LED (near F1) to blink red indicate low voltage
    Nitin Patil, 2020-01-31 16:25:00 -05:00
  3. rkG
    rkG Member
     

    Hi, thanks for the information. But my variable power supply was set to 9V and the max current pulled is ~0.5A. So I don’t understand why or how the voltage could be dropping so much to cause the program to fail. Has this occurred before, do you have any idea how to fix such an issue? 

    Thank you in advance!
    rkG, 2020-01-31 17:32:01 -05:00
  4. Nitin Patil
    Nitin Patil Member Staff Member
    Are you using Wire with Good guage to connect your PiStorms with your DC bench supply ??
    Try heavier guage, that might help
    Nitin Patil, 2020-02-03 14:06:42 -05:00
  5. rkG
    rkG Member
    Hi Nitin,

    Unfortunately, I don't think it is the wire guage. The moment I noticed my problem occuring, my first action was to twist 2 wires together to increase the current capacity, but that did not yield any improvement nor did the current being pulled increase. :( 

    I'll keep trying different possibilities.

    Thanks


    rkG, 2020-02-04 06:20:21 -05:00
  6. (You must log in or sign up to post here)

Log in | Sign up
Tems & Conditions!
Help!