MTRMX-Nx stopped working
 Hardware Related   Started by Alittlesloww S   2015-09-11 15:43:59 -04:00   Comments: 4    Viewed: 507

  1. Postby ALittleSlow » Fri Dec 28, 2012 12:21 pm

    My MTRMX-Nx was working fine last night. I unplugged it from power and shut down the NXT. This morning I made a software change, but when I tried to run the program I got no activation of the motors attached to the MTRMX-Nx.

    I am using a power supply rated at 12VDC, 750ma. It shows 13.5V at the MTRMX power connector at idle.
    Last night I was using it to power a total of 6 PowerFunctions medium motors (two pairs of motors on two ports and one motor each on the other two ports). I ran this setup for about four hours for as long as 15 minutes continuously. The ICs were not noticeably warmer when running than when idle, and were never hot.

    This morning, I made no changes to the electrical or mechanical configuration. The most significant software difference was that I moved the SetSensorLowspeed() command from just before the I2C commands to--nowhere. That is, I intended to move it, but only succeeded in deleting it. Does this mean I attempted to drive the MTRMX-Nx in analog mode?

    When the MTRMX-Nx is plugged into the sensor port, its LED blinks 3 times, the 4 times (I think), just as it has always done.

    To troubleshoot, I disconnected all but one motor, unplugged the board from power and from the NXT, and pulled the battery from the NXT. Then I shorted the power connector leads on the MTRMX-Nx until it showed 0V. After reconnecting, I ran the MTRMX-Nx demo program. Still no joy.

    Any suggestions on further troubleshooting or on what might have caused the board to fail?
    Alittlesloww S, 2015-09-11 15:43:59 -04:00
  2. Mindsensors Support
    Mindsensors Support Member Richmond

    Postby support » Fri Dec 28, 2012 12:23 pm

    MTRMX-Nx is an I2C device.
    To initialize the I2C interface on NXT, SetSensorLowspeed() is needed.
    Mindsensors Support, 2015-09-11 15:44:29 -04:00
  3. Postby ALittleSlow » Fri Jan 18, 2013 10:19 pm

    I guess I should have added that I had put SetSensorLowspeed() back in, but still got no response. Is it possible to fry it by not running it "Lowspeed"? What's the next diagnostic step?

    Thanks.
    Alittlesloww S, 2015-09-11 15:44:48 -04:00
  4. Mindsensors Support
    Mindsensors Support Member Richmond

    Postby support » Fri Jan 18, 2013 10:23 pm

    download the 'Explorer' program from following url:
    /content/15-explore-devices-attached-to-nxt-or-ev3
    (that url also has url for instructions on how to install the program on your NXT.)
    Attach the MTRMX-nx to Port 1 and run the explorer, that should tell you sensor information on NXT screen.
    If you get meaningful info, that means your sensor is responding to NXT.
    Mindsensors Support, 2015-09-11 15:44:58 -04:00
  5. (You must log in or sign up to post here)

Log in | Sign up
Tems & Conditions!
Help!